Asahi Linux, compatible con OpenGL 4.6 en los chips de Apple

miércoles, 6 marzo 2024
Asahi Linux, compatible con OpenGL 4.6 en los chips de Apple

Durante varios años, los chips M1 y M2 de Apple solo eran compatibles con OpenGL 4.1. Los desarrolladores de Asahi Linux anunciaron recientemente el soporte completo para OpenGL 4.6 y OpenGL ES 3.2.

Estos controladores de código abierto para Linux son compatibles con las últimas versiones de OpenGL, prometiendo una amplia compatibilidad con cargas de trabajo modernas de OpenGL, como puede ser con Blender, Ryujinx y Citra.

Captura de pantalla de Blender en funcionamiento en Apple M1 con Fedora Linux 39. La escena es 'Wanderer', que representa un humanoide en traje espacial en un terreno rocoso, junto a un vehículo con paneles solares.

Captura de pantalla de Blender en funcionamiento en Apple M1 con Fedora Linux 39. La escena es ‘Wanderer’, que representa un humanoide en traje espacial en un terreno rocoso, junto a un vehículo con paneles solares.

Los controladores tuvieron que superar más de 100.000 pruebas para garantizar el correcto funcionamiento. Aunque el fabricante aún no soporta estándares gráficos como el OpenGL moderno, Asahi Linux ya lo hace.

En comparación con 4.1, el OpenGL 4.6 añade muchas características necesarias, incluyendo:

– Robustez
– SPIR-V
– Control de recorte
– Distancia de eliminación
– Shaders de cómputo
– Retroalimentación de transformación mejorada

Más información

Balance do Plan de Acción 2023

1 Diciembre 2021 Informe

Plan de Software Libre 2024

1 Diciembre 2021 Informe

#IA #PlanDeAccion #EntrevistasComunidad

Tendencias
Xunta

Xunta de Galicia, Información mantenida y publicada en internet por Xunta de Galicia

Atención a la ciudadanía - Accesibilidad - Aviso legal - Mapa del portal