Asahi Linux, compatible con OpenGL 4.6 nos chips de Apple

Mércores, 6 Marzo 2024
Asahi Linux, compatible con OpenGL 4.6 nos chips de Apple

Durante varios anos, os chips M1 e M2 de Apple, soamente foron compatibles con OpenGL 4.1. Os desenvolvedores de Asahi Linux anunciaron recentemente o soporte completo para OpenGL 4.6 e OpenGL ES 3.2.

Estos controladores de código aberto para Linux son compatibles coas últimas versións de OpenGL, prometendo unha ampla compatibilidade con cargas de traballo modernas de OpenGL, como pode ser con Blender, Ryujinx e Citra.

Captura de pantalla de Blender en funcionamento no Apple M1 con Fedora Linux 39. A escena é 'Wanderer', que representa un humanoid en traxe espacial nun terreo rochoso, ao carón dun vehículo con paneis solares.

Captura de pantalla de Blender en funcionamento no Apple M1 con Fedora Linux 39. A escena é ‘Wanderer’, que representa un humanoid en traxe espacial nun terreo rochoso, ao carón dun vehículo con paneis solares.

Os controladores tiveron que superar máis de 100.000 probas para garantir o correcto funcionamento. Aínda que o fabricante aínda non soporta estándares gráficos como o OpenGL moderno, Asahi Linux xa o fai.

En comparación con 4.1, o OpenGL 4.6 engade moitas características necesarias, incluíndo:

– Robustez
– SPIR-V
– Control de recorte
– Distancia de eliminación
– Shaders de cómputo
– Retroalimentación de transformación mellorada

Máis información

Balance do Plan de Acción 2023

1 Decembro 2021 Informe

Plan de Software Libre 2024

1 Decembro 2021 Informe

#IA #PlanDeAccion #EntrevistasComunidade

Tendencias
Xunta

Xunta de Galicia, Información mantida e publicada na internet pola Xunta de Galicia

Atención á cidadanía - Accesibilidade - Aviso legal - Mapa do portal